Report Builder 3.0 and Internet Explorer 9 (Beta): Why can’t they just play nice…?

A few months ago I decided to install Internet Explorer 9 (Beta), and everything was nice and dandy until I had to install SQL Server 2008 R2 for a new project.

Initially I had some issues with Windows 7’s UAC (more info here) and getting access to Reporting Services. The only way around it (after everything else didn’t work) was to disable UAC completely (just temporarily, to add myself as an admin in SSRS)…sometimes the “divide and conquer” strategy is all you have left in your little bag-o-tricks.

Report Builder was next, and the following series of events (comical, and to my embarrassment) ensued:

Me: Report Builder link…<click>.

Report Builder: “Please ensure that the .Net framework version 3.5 is installed”…or something to that effect.

Me: <Click on the link to install .Net 3.5>. Error…but no message.

Me: <Try another link to install the redistributable package>. Error. Apparently I have to go to “Control Panel > Programs and Features > Turn Windows features on or off” to enable it.

Me: “Hmmm…ok…silly me.” <Enable Windows Feature><bounce>.

Report Builder: Same message…

Me: “Google, my old friend!!” I find a post that suggests that I remove all other versions of the .Net framework.

Me: “Ok, sounds like a plan. This could also be a good opportunity to clean up all those previous versions of SQL Server on my machine.”

Me: <Remove all previous versions of .Net and SQL Server><bounce>

Report Builder: Same thing…

Me: “#$%^#??!!!” I got nothing…

Yesterday arrives, and I decide to do my taxes. To my astonishment, the site I use to complete and submit my taxes does not work with IE 9 and I am forced to uninstall it (at least for the moment). It must have been sometime during that process that a little light came on in my head, and for no apparent reason I think to myself: “I wonder what Report Builder would say now that I have done that?”

I probably don’t have to tell you what happened next (eureka!!!), but it seems like it is not only my tax company that has angry feelings towards IE 9…

 

Update (March 24, 2011)

Since the release of Internet Explorer 9 RTM, I decided to give it another try. Report Builder now works with Internet Explorer 9, but only if you view the Reporting Services website in compatibility mode.

Advertisements
Report Builder 3.0 and Internet Explorer 9 (Beta): Why can’t they just play nice…?

5 thoughts on “Report Builder 3.0 and Internet Explorer 9 (Beta): Why can’t they just play nice…?

  1. stolan says:

    Fantastic! – I’d tried everything – for hours – to get Report Builder to work (except this, of course) and was ready to give up. What a complete waste of time!
    It’s obvious that PRODUCTIVITY and MICROSOFT are two words that will never go together. They can’t even get their own products to work correctly on their own OS.

    1. Glad the post helped. From a MS point of view, I can understand that all products cannot always be in sync and 100% compatible when new releases come out, but it sure is frustrating sometimes.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s